This article explains what the various Paazl SOAP API status codes mean.
Note
Make sure you check for a success response or an error response every time you send a request to Paazl's SOAP API web service.
Sample error response
Paazl's SOAP API error response XML has the following format.
<errorResponse xmlns="http://www.paazl.com/schemas/matrix">
<code>1000</code>
<message>no valid hash</message>
</errorResponse>Codes
Note
The error codes below are those generated by Paazl. It is possible that carriers also generate their own error codes.
| Code | Explanation |
|---|---|
| 1000 | No valid hash The hash is usually incorrect because the string you hashed to get the SHA-1 hash code is incorrect. See SOAP authentication for an explanation of how to correctly format strings for hashing. |
| 1001 | The submitted webshop ID is unknown. |
| 1002 | No order found with given reference What to do: Make sure that the order reference you have submitted exists in your webshop. The carrier concerned may be an unsupported Cassandra carrier. Contact Paazl Customer Support to find out which Cassandra carriers are supported. |
| 1003 | An order with this reference already exists If you receive this message after submitting an order API request—which creates new orders—you may want to use the |
| 1004 | The zipcode and house number combination does not exist Note Paazl validates Dutch addresses using the Postcode.nl database. New addresses may not yet be in the database. Paazl will then return an error message. You can either register the address concerned with Postcode.nl or switch off address validation. |
| 1005 | The status of this order is unknown. Contact Paazl Customer Support. |
| 1006 | No total amount for the order is submitted |
| 1007 | The total amount submitted is in the wrong format (e.g. non-numeric) |
| 1008 | An unknown country code is submitted |
| 1009 | The assured amount is not submitted |
| 1010 | The assured amount is incorrect (minimum of 500, maximum of 5000, multiple of 500) |
| 1011 | The maximum amount of labels is incorrect |
| 1012 | Incorrect notification service for the servicepoint submitted. You are required to submit an email address ( |
| 1013 | There are no shipping options available. Possibly no shipping options are assigned to your Paazl account. Another reason may be that the matrix configurations are incorrect. |
| 1014 | The telephone number required for DPD 'before 10.00' and '12.00' shipments is not submitted. |
| 1015 | This shipment requires a valid customs value. |
| 1016 | Distributor replied with an error message |
| 1017 | This type of shipment requires each product to be fully defined. This error code will be returned in case a Fedex or Dynalogic shipment did not come with the required package content values. |
| 1018 | This shipping option does not support date preference |
| 1019 | Invalid date specified for this shipping option |
| 1020 | Labels have already been generated for this (Dynalogic) order and cannot be regenerated. A Dynalogic shipment can only be pre-registered/printed once. |
| 1021 | This order requires a non-zero order weight |
| 1022 | This order requires a description |
| 1023 | Invalid license key supplied |
| 1024 | This order cannot be changed |
| 1025 | This order contains errors |
| 1026 | Delivery Date module is inactive |
| 1027 | This order requires an e-mail address |
| 1028 | No such barcode |
| 1029 | Labels for this shipment cannot be regenerated |
| 1030 | Invalid or missing shipping option |
| 1031 | No pickup request options available |
| 1032 | Invalid or missing pickup window |
| 1033 | This pickup contains errors |
| 1034 | No such distributor |
| 1035 | No such pickup request |
| 1036 | No such pickup request option |
| 1037 | This pickup cannot be cancelled |
| 1038 | This code can be accompanied by a variety of error messages:
|
| 1039 | No delivery estimates available |
| 1040 | No shipping options available after filter |
| 1041 | Invalid distributor |
| 1042 | No compatible open shipment batch available |
| 1043 | No such shipment batch |
| 1044 | This shipment batch has already been closed |
| 1045 | Ambiguous delivery estimate request |
| 1046 | Package content determines package count |
| 1047 | Invalid or missing changed since date |
| 1048 | Upstream server error |
| 1049 | Invalid destination |
| 1050 | Invalid or missing service point code |
| 1051 | Invalid or missing service point account number |
| 1052 | No checkout session available for this order |
| 1053 | Missing permission What to do: Contact Paazl Customer Support to have the feature 'Adding existing shipments' enabled. |
| 1054 | No barcode given |
| 1055 | No proof of delivery document available |
| 1056 | Invalid daterange |
| 1057 | Order changed by concurrent request |
| 1058 | Unsupported operation |
| 1063 | Parcel already exists What to do: Make sure the parcel code you enter isn't the same as a previous parcel code in the addExistingShipment request or doesn't already exist in Paazl. |
| 1064 | Parcel processing failure What to do: Check the addExistingShipment response to see which parcels failed. These will be indicated by a barcode and order reference. If the problem is due to a duplicate barcode, you will have to supply the parcel with a unique barcode or delete it from the request. |
Was this article helpful?
That’s Great!
Thank you for your feedback
Sorry! We couldn't be helpful
Thank you for your feedback
Feedback sent
We appreciate your effort and will try to fix the article